[Q&A]flutter/「Building with plugins requires symlink support.Please enable Developer Mode in your system settings.」

1月 4, 2024
0 0
Read Time:22 Second

Q)

以下のメッセージが表示されました。なぜですか?どうすればいいですか?
> flutter run -d windows
Launching lib\main.dart on Windows in debug mode…
Error: Building with plugins requires symlink support.
Please enable Developer Mode in your system settings.
Run start ms-settings:developers to open settings.

A)

このエラーメッセージは、FlutterプロジェクトをWindowsで実行しようとした際に、プラグインを使うために必要なシンボリックリンク(symlink)がサポートされていないことを示しています。Windowsでシンボリックリンクを使用するには、開発者モード(Developer Mode)を有効にする必要があります。

解決策としては、以下の手順を実行してください:

1.「スタートメニュー」を開き、「設定」にアクセスします。

2.「更新とセキュリティ」を選択し、「開発者向け」オプションに移動します。

3.「開発者モード」を選択して有効にします。

これにより、Windows上でシンボリックリンクが利用できるようになり、Flutterプロジェクトのビルドが可能となります。設定を変更した後は、コンピュータを再起動することをお勧めします。

Happy
Happy
0 %
Sad
Sad
0 %
Excited
Excited
0 %
Sleepy
Sleepy
0 %
Angry
Angry
0 %
Surprise
Surprise
0 %

Average Rating

5 Star
0%
4 Star
0%
3 Star
0%
2 Star
0%
1 Star
0%

コメントを残す